[v6 General Discussion] Limited User Account - Win7

Hi All,

I've tried a few times to get thorough to tech support this afternoon, but failed and the queue is full now. Anyhow, thought I would post here instead and hope for some help.

I've been running EW2009 on my church media PC for ages now.
It is a dell PC with additional nVidia GFX card and a matrox Dual head2go VGA splitter for the projector and foldback outputs.
I've had 2 admin accounts for me and another techy, and the worship account has been limited user.
I've also been running Microsoft Family Safety (Part of Microsoft Live Essentials) primarily to prevent the limited user account from going onto the internet and installing other software.
I consider the worship PC to be a 'production machine' and don't want it messed up - as I will be the one fixing it - and if it fails during the service, then I will have failed in my job as a techy guy. I don't want this to ever happen.

So last night I tried to install EW6 on the machine.
Did a backup, installed the new version from the admin account and then the upgrade of the database went fine once I had pointed the to the files. All in the admin account.
Then logged into the worship account which has type - limited user.
EW6 would not run,
I kept getting parental controls popping up asking for permission to run the software - which I tried to grant - but with no success.
In the end I removed Microsoft Family Safety and un-installed Microsoft Live Essentials as well as unlinking the 'kids' accounts from my 'parent' account in live.com
As far as I can see, all traces of the parental controls have been removed, and I still cant run EW6 in the limited user account.

What happens now is that you can double click the icon on the desktop or in the start menu. You sometimes get the helper open in the task area tray on the right. If you right click on that icon and choose Launch Easyworship, then it opens.
The other way to get it to open is to right click on the icon and choose run as administrator.

This is not really workable for everyone to remember how to run the software.

I've also tried folowwing advice from this post: viewtopic.php?f=45&t=13702&p=46629&hilit=administrator#p46629 and downloading the permission fix tool, but this didn't help.
https://easyworship.com/downloads/Utili ... ta-7-8.exe

Any ideas people?

All help and advice gratefully received. Thanks and God bless you in advance.


What is the path to the database. You said you repointed the profiles to the admin account.
This would definitely cause an issue with accessing the database.
The permissions fix tool only affects the profiles stored in public documents.
You'll have to manually change the permissions on the EasyWorship profile folders to allow full access to everyone.
Hi Rodger,

Many thanks for your reply.

I am not in front of the PC, but I can confirm that the data is held below the following folder: C:\Users\Public\Documents\Softouch

I also remember manually checking that the folder had all permissions for 'everyone'.
It is the same path that EW2009 was using.

Any further things to check?


Browse to the profile folder, then open v6.1\databases\
Right click on data and set the permissions so that everyone has full control of that folder.
This is an issue that will be fixed in the next build release(6.1.7), which should be fairly soon.