[v7 General Discussion] No audio going to stream PC


I am using two PC's, one with EasyWorship and the other with vMix which streams live.

The vMix pc isn't receiving the audio from EasyWorship. Whether I play a video, audio file, whatever, the audio is not being sent to vMix.

I am using NDI for everything. Our cameras are NDI, as well as the stream from EasyWorship to vMix.

I've tried adding a "feed" to EasyWorship, but there's no option for an "audio feed" so I assume this isn't the issue. I've looked through all the EasyWorship settings a hundred times and there's nothing I can find to remedy this.

FYI: currently I am using the computer's line in port for the audio that comes from our sanctuary (mics). Regardless, this audio is not getting to vMix, nor any other audio that EasyWorship is supposed to be NDIing over.

I'm not 100% sure this is an EasyWorship issue or a vMix issue, but according to the vMix website, the audio is supposed to be automatically added to the NDI stream that is received. I don't hear it; the audio button on the vMix input for the EasyWorship NDI stream is green (on). No sound.

Suggestions?? Am I missing something??

That sounds like VMix isn't correctly configured to accept your audio feed. You will probably get more help asking this on a VMix forum, user group. or Facebook group.
I found the solution, which seems quite strange to me. I plugged in a set of headphones to the speaker out on the PC with easyworship, and immediately the vmix pc started receiving the audio from the NDI stream. As soon as I unplugged the headphones, the audio stopped. Windows does have a feature which will shut off audio if no devices are plugged into an output jack. But why would this mess with ndi streams?? Seems like there's something in the easyworship software that should overcome this.
Currently I am running EW And vMix on the same PC with Ew set to output to NDI I have an NDI feed coming into vMix. I am playing a video in EW. The audio was coming through but if I turned up the volume in vMix I got a lovely - well not so lovely sound loop.

I clicked on the little cog on the NDI audio feed and opened up the channel Matrix. You see some green squares and some blank ones. I closed all but then opened the two top left - Master L and Master R. I now have happy audio at full vMix volume and my audio indicator is showing audio in vMix.

Try playing with thsoe settings in vMix