PowerPoint displays black on NDI stream

I have two computers, one is a Surface Pro 4 (let's call this "A"), the other a Surface Laptop 2 ("B")

I have set up B in the same way as A as far as possible and the only remaining issue is one with PowerPoint over NDI. I have reviewed all the other cases I can find and none of them gives a satisfactory fix as far as I can tell.

BOTH machines have:

  • Easy Worship
  • OBS 26.1.1
  • PowerPoint 2016
  • Windows 10 (A has Enterprise, B has Home)

I run Easy Worship on both laptops, both using NDI - PAL 1920 x 1080 25Hz for output, playing the same PowerPoint slide presentation and the same song..

Both machines are on the same LAN, so I can see both NDI streams on both machines.

Here's what happens:

  • OBS on A with NDI from A => PowerPoint and Song are fine
  • OBS on B with NDI from B => Song is fine, PowerPoint black
  • OBS on A with NDI from B => Song is fine, PowerPoint black
  • OBS on B with NDI from A => PowerPoint and Song are fine

In short, on both machines, all is well when NDI comes from the Surface Pro but PowerPoint is black when NDI comes from the Surface Laptop.

I could could really do with some help to fix this. I am moving off the Surface Pro because its screen is defective and difficult to work with. It is not an option to keep the Surface Pro.

Thank you

3 people have this question

We are having same problem here this week on our church livestream.  We are new to the live stream system running EW7 to vMix.  The first few weeks things worked fine where both the songs and powerpoint output worked like a charm.  Now, the songs display on output but the Powerpoint is just a black screen.  Can't seem to figure it out in reading troublshooting from EW and vMix.  Figure it has something to do with the computer running the live stream or the vMix since the in-house production computer isn't having any issues with it's EW7 outputs.

Our new laptop runs with Intel UHD graphics.  Which it appears from the EW troubleshooting guides is unsupported.  If it were the graphics card giving us the trouble, I'm thinking it wouldn't have displayed properly the first few weeks.

Odd to run across you guys having a similar problem at the same time so making me think it's a glitch in EW.  Would love to hear if you figure anything out as I'm at my wits end here trying to sort it out.


I have exactly the same problem with powerpoint over NDI. The strange thing is, it happend simultaneously on two computers in the last week. It had work flawlessly the weeks before. All of my software is up to date.

Thank you

The only thing I can think of would to make sure that you have the most current NDI tools installed from this link https://ndi.tv/tools/#download-tools

Login to post a comment